#175 ✓invalid

0.5.1 gem is not compatible with rails <=2.3.9

Reported by zenbu | September 14th, 2010 @ 02:15 PM

The 0.5.1 gemspec says
s.add_dependency 'rails', ">= 3.0"

so using it with rails 2.3.9 causes a

can't activate activesupport (= 3.0.0, runtime) for ["railties-3.0.0"], already activated activesupport-2.3.9 for ["rails-2.3.9"]

talks about this as a potential gemspec issue.

It's not obviously specified that 0.5.1 is only for Rails 3+. If 0.5.1 was only fixing the DEPRECATION warnings started with Rails 2.3.9 then it probably is compatible with Rails 2.

Comments and changes to this ticket

  • Jens

    Jens September 14th, 2010 @ 05:23 PM

    • State changed from “new” to “invalid”


    actually that's exactly what I intended. Aaf versions from 0.5 onwards are Rails3-only because of the new railties based plugin integration stuff.

    Please use the 0.4.x versions (or the newly created rails-2.3.x branch on github) for Rails versions < 3.0. I'll continue to integrate bug fixes and improvements there as needed.

    But you're right, I'll make that more clear in the README.


Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

Shared Ticket Bins

People watching this ticket